Loading

[2.1] Configure Email for Amazon SES - RESOLVED

Get help with problems, or report & discuss bugs in Collabtive

Re: [2.1] Configure Email for Amazon SES

Postby some person » 07.05.2015, 04:28

I think the problem is with the autoloader.

PHPMailer is calling for 'SMTP' class and autoloader is trying to load class.SMTP.php, but the actual filename is class.smtp.php.

Rename the class.smtp.php file to class.SMTP.php and see if that fixes your problem
some person
 
Posts: 439
Joined: 16.04.2011, 12:46

Re: [2.1] Configure Email for Amazon SES

Postby abarker » 07.05.2015, 16:37

That was the final piece to the puzzle! Thanks for your help!

For anyone checking into this, the necessary fix involves:

  1. Upgrade class.PHPMailer.php and class.SMTP.php to latest (make sure not to mess up the capitalization as I did). Link for the repository: https://github.com/PHPMailer/PHPMailer
  2. Make sure to use a port other than 25. If the AWS region you are using requires port 25, you may be out of luck.
  3. Save your SES credentials in Collabtive in plaintext, not base64 encrypted.

In the end, your settings should look something like:

email.png
email.png (24.17 KiB) Viewed 6751 times
Last edited by abarker on 07.05.2015, 22:48, edited 1 time in total.
Running Collabtive 2.1 on Amazon Linux AMI 2015.03, PHP 5.6.8, MySQL 5.5.42
abarker
 
Posts: 10
Joined: 30.04.2015, 17:04
Location: Arizona, United States

Re: [2.1] Configure Email for Amazon SES - RESOLVED

Postby Eva » 07.05.2015, 21:18

Glad to hear that you found a solution and can use the notifications now! :)
...and thx for providing the explanation.
Project Management the way you like it: Collaborative - Open Source - Free

facebook.com/Collabtive
twitter.com/Collabtive
xing.com/companies/collabtive
linkedin.com/company/collabtive
User avatar
Eva
 
Posts: 1471
Joined: 01.01.2008, 23:31
Location: Saarbrücken, Germany

Re: [2.1] Configure Email for Amazon SES

Postby some person » 08.05.2015, 10:23

abarker wrote:
  1. Upgrade class.PHPMailer.php and class.SMTP.php to latest (make sure not to mess up the capitalization as I did). Link for the repository: https://github.com/PHPMailer/PHPMailer

This actually was not your fault. In collabtive, by default, this file is not named correctly.

It is quite possible that other people using collabtive will also run into this problem.

I did not notice this problem at first as I was testing this on a Windows system, and Windows is not case sensitive when it comes to file and directory names.
some person
 
Posts: 439
Joined: 16.04.2011, 12:46

Previous

Return to Problems and Bugs

Who is online

Users browsing this forum: Google [Bot]