Loading

[3.0.1] Comments for Tasks not loading properly

Get help with problems, or report & discuss bugs in Collabtive

[3.0.1] Comments for Tasks not loading properly

Postby Wroth » 19.05.2017, 01:17

Having an issue with the Comments for Tasks plugin.

Going to the Tasklist and expanding a task to see details and comments, does not display comments. Only a 'Comments' area which is empty besides the add comment button. No matter how many comments are on to the task they don't initially show.

The only way to make them show is to add a new comment. Once it is submitted it updates the page and all the older comments show.

The .commentsWrapper element is not populated with .taskcomments initially, just empty space. Once you add a new comment, the .taskcomments is loaded and old comments are shown. As you can see from the attached screenshots.

Thoughts on the cause / a solution?



Our install version is 3.0.1. We recently moved to a new server, updated our v2 installation to v3 and installed the plugin.
Attachments
Untitled-1.jpg
Before and after shots when posting a new comment. Before list is empty, after list is shown.
Untitled-1.jpg (138.26 KiB) Viewed 11015 times
Wroth
 
Posts: 12
Joined: 19.04.2016, 23:43

Re: [3.0.1] Comments for Tasks not loading properly

Postby Eva » 03.06.2017, 16:25

Which browsers did you use?
Project Management the way you like it: Collaborative - Open Source - Free

facebook.com/Collabtive
twitter.com/Collabtive
xing.com/companies/collabtive
linkedin.com/company/collabtive
User avatar
Eva
 
Posts: 1471
Joined: 01.01.2008, 23:31
Location: Saarbrücken, Germany

Re: [3.0.1] Comments for Tasks not loading properly

Postby Wroth » 05.06.2017, 10:22

Up to date versions of Firefox, Chrome, and Safari are all affected — we have not tried Edge yet. Rest of our server setup for the record is Apache 2.2.32, PHP 5.4.24, MySQL 5.6.32…

It does not seem like a browser displaying problem to me because the content of the comment list is initially missing from the page source. Seems the comment list is just not getting added to the page initially, only appears after a new comment is committed which refreshes the list and then it loads.

Thank you for finding the time to reply Eva.
Wroth
 
Posts: 12
Joined: 19.04.2016, 23:43

Re: [3.0.1] Comments for Tasks not loading properly

Postby Wroth » 18.09.2017, 19:22

Any updated thoughts on this problem?
Wroth
 
Posts: 12
Joined: 19.04.2016, 23:43

Re: [3.0.1] Comments for Tasks not loading properly

Postby Philipp » 02.12.2017, 22:31

This has actually been fixed.

See this commit:
https://github.com/philippK-de/Collabti ... 5ac99e9ee1

this will be included in the upcoming 3.2 release.

To get this fix now, replace the existing class.task.php in your installation with the one from github.
User avatar
Philipp
Site Admin
 
Posts: 1118
Joined: 14.12.2007, 03:06
Location: Saarbrücken, germany


Return to Problems and Bugs

Who is online

Users browsing this forum: No registered users