Page 1 of 1

[3.0.2] Can't upload files into Root or Sub Directories

PostPosted: 21.06.2017, 07:15
by JimmyC
Hello everyone! I have used Basecamp where I used to work but am on my own now. I am new to Collabtive and have just installed for the first time version 3.0.2. :D After extracting my files onto a Host Server (Apache 2.2, PHP 5.6, MySQL 5.6, Perl 5.10), the following was done before running install:
- /templates_c > 777
- /files > 777
- /config/standard/config.php > 777
- PHP Safe Mode OFF

After installing and creating a Project, I tried to upload files to the root directory and a blank progress bar showed for a few seconds and the screen refreshed but no file was shown in the directory. I then created a sub-directory and tried to upload a different small (68kb) file and it did not upload. Again there were no warnings or errors flashed, just the screen refreshing and the directories remaining empty. :( I then went to Edit User and uploaded an Avatar for me and this worked!

Finally I went into cPanel File Manager and opened the "public_html/****/collabtive/error_log" and it only showed this one error for every time I started Collabtive:

PHP Warning: Illegal string offset 'ID' in /****/public_html/****/collabtive/templates_c/332fb21eb0b1b5ffbeccf7bb5ef42dca962e5464_0.file.addproject.tpl.php on line 132

I checked the GitHub latest bug fixes about problems uploading files and they were implemented by version 3.0.1. Since the error is in a templates_c file, this leads me to think something is not properly configured by me. :cry:

Any help would be greatly appreciated and I will respond in detail with whatever fixes my problem. :)

Thank you all for your time and consideration!

Re: [3.0.2] Can't upload files into Root or Sub Directories

PostPosted: 21.06.2017, 13:53
by JimmyC
I just tried to use the Demo on your website and for me it replicates the same problem I am having. That is, I try to upload any kind of file any size, it does not upload and does not give any indication of failure. I am using Chrome browser ( and also tried Mozilla Firefox) on a Windows 10 x64 laptop.

Has anyone been able to upload files using the online Demo?

Re: [3.0.2] Can't upload files into Root or Sub Directories

PostPosted: 21.06.2017, 18:24
by JimmyC
To do further research, I installed 3.0.1 and it also didn't work ( would not upload any kind or size of files into the "Files" tab).

Then I tried version 3 with the same results of not being able to upload.

Sooooooo... I installed 2.1.1 and I am finally able to upload using the "Desktop/Project/Files/AddFile" tab path!!!!! :D :D :D :D

Now I am able to at least start using this program to collaborate with the rest of the members of our company (2 others for a total of 3 people working on our concept).
All three of us live in different states here in the USA separated by 300 mi for one and 1200 mi for the other.

Hopefully this information will help you to correct the problem I have encountered if this is a real problem with the software and not just a configuration error on my part.

By the way, I really liked the fact that on version 2.1.1 that the current users online are listed. The minimum should be showing yourself being logged in just like it is shown on this website.

Thank you all again for your patience and hard work on this great program!